How IRRITATING! - Tropical Fish Keeping - Aquarium fish care and resources
 
LinkBack Thread Tools
post #1 of 7 Old 07-22-2013, 10:53 PM Thread Starter
How IRRITATING!

Woke up this morning around 830 to feed my fish in my 75 gallon to find my Penn Plax heater had busted! The bottom completely busted out. Only about 6-7 months old. Thank GOD I have 2 heaters in my aquarium. I'm really irritated. This is my second heater to malfuntion in as many weeks. The first was a Marineland 75w that quit working in my saltwater tank after just 3 days, and now this one. That's it, I'm only buy eheim from now on. PFFFT

4 gallon betta tank
75 gallon FW community
20 gallon SAP tank
10 gallon snails
NewFishFiend is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 07-23-2013, 02:55 AM
Member
 
jaysee's Avatar
 
I just had a heater malfunction in one of my quarantine tanks - killed my new fish. $50 in the garbage, literally. I'm sure glad that my show tanks are unheated.


Sent from Petguide.com App

125 - BGK, chanchito cichlid, pictus cats, silver dollars, palmas bichir
125 - cichlids (severums, bolivian rams, chocolate), rainbows ( turquoise, red), loaches (angelicus, zebra, kuhli and horseface), plecos (BN, RL and clown), denison barbs, tiretrack eel, pearl gouramis, betta
90 - Congo tetras, african knife, upside down cats, spotted ctenopoma, kribensis, delhezzi bichir
2.5 - betta
jaysee is offline  
post #3 of 7 Old 07-23-2013, 04:21 AM
TFK Moderator
 
Romad's Avatar
 
The odds of that happening are pretty low with two different brands in so little time. Are you using a surge protecter strip (assuming they were both plugged into the same socket)?

Animal testing is a terrible idea; they get all nervous and give the wrong answers.
Romad is offline  
post #4 of 7 Old 07-23-2013, 03:51 PM Thread Starter
Quote:
Originally Posted by Romad View Post
The odds of that happening are pretty low with two different brands in so little time. Are you using a surge protecter strip (assuming they were both plugged into the same socket)?
I use surge protectors. 2 different tanks, two different rooms. The marineland just stopped heating. The light was on but it didnt heat. The penn plax literally busted out the bottom.

4 gallon betta tank
75 gallon FW community
20 gallon SAP tank
10 gallon snails
NewFishFiend is offline  
post #5 of 7 Old 07-23-2013, 06:01 PM
Reference Team
 
Agent13's Avatar
 
Fluval and eheim.. I would swear by no others
Agent13 is offline  
post #6 of 7 Old 07-24-2013, 11:24 AM
Member
 
Tracy Bird's Avatar
 
I have an opinion but I'll not share it as I'm certain I will JINX myself.

Looks like you didn't lose any livestock, so thats a good thing and you are only out the cost of the heater....

Have fun and be PATIENT!
Tracy Bird is offline  
post #7 of 7 Old 07-25-2013, 03:39 AM Thread Starter
Quote:
Originally Posted by Tracy Bird View Post
I have an opinion but I'll not share it as I'm certain I will JINX myself.

Looks like you didn't lose any livestock, so thats a good thing and you are only out the cost of the heater....
Very true. My 75 gallon is hanging out at 74 degrees (normally 78) because the 1 heater just can't really keep up (we keeps it chilly in our house lol) and I haven't been able to pick up a new heater yet. Marineland is replacing the one in my saltwater tank, but it's still frustrating.

4 gallon betta tank
75 gallon FW community
20 gallon SAP tank
10 gallon snails
NewFishFiend is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome