Have a problem with brown alge - Page 2 - Tropical Fish Keeping - Aquarium fish care and resources
LinkBack Thread Tools
post #11 of 12 Old 04-07-2012, 03:46 PM
New Member
I don't know how far you are willing and able to travel, but I found these threads for NJ stores.

looking for the largest aquarium fish store in NJ

TwinDad is offline  
The Following User Says Thank You to TwinDad For This Useful Post:
jcngo (04-08-2012)
Sponsored Links
post #12 of 12 Old 04-08-2012, 02:36 PM
rhymon78's Avatar

I would just like to add that I too use the API master test kit for my water testing, and had trouble with the ammonia levels to begin with...

I was constantly reading 0.25ppm ammonia and it was driving me nuts, but I think that the colour is misleading. I always thought that the test tube water looked ever so slightly green, and then sometimes it looked yellow. I had my water tested at my LFS, they use a different brand of test kit, and the ammonia level wasn't registering at all on their test. So I wouldn't unduly sweat about that ammonia level, unless your 100%sure its more than 0ppm.

Just seems coincidental that your experiencing the same problem that I faced.

Like Byron and the others said, live plants is the way to go! even if it means hunting them down. they look much better, and according to all the info I have attained from this forum they do the water and fish no end of good! and the whole ammonia, nitrite worry.....becomes a non worry really.

all the best
rhymon78 is offline  
The Following User Says Thank You to rhymon78 For This Useful Post:
jcngo (04-08-2012)

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Forum Replies Last Post
Brown algae problem Ami Beginner Planted Aquarium 10 08-19-2011 10:53 AM
Help ALGE? fry1goat Beginner Freshwater Aquarium 6 03-01-2009 08:24 AM
Brown Algae Problem! HELP! JHK30 Beginner Freshwater Aquarium 15 01-07-2009 12:32 AM
Problem with Aquarium/Vivarium Water Turning Brown naamahbengals Vivariums and Reptiles 2 07-16-2008 12:25 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome