Green spot and ????? Algae –what is not right?
Tropical Fish

Tropical Fish Keeping - Aquarium fish care and resources » Freshwater Fish and Aquariums » Beginner Freshwater Aquarium » Green spot and ????? Algae –what is not right?

Green spot and ????? Algae –what is not right?

This is a discussion on Green spot and ????? Algae –what is not right? within the Beginner Freshwater Aquarium forums, part of the Freshwater Fish and Aquariums category; ...

Check out these freshwater fish profiles
Serpae Tetra
Serpae Tetra
Filament Barb
Filament Barb
Reply
LinkBack Thread Tools vBmenu Seperating Image Search this Thread vBmenu Seperating Image
Green spot and ????? Algae –what is not right?
Old 12-14-2009, 09:38 PM   #1
 
Green spot and ????? Algae –what is not right?

Hello. Here is some pics of my problem. What is it and how I can fix it.
40gal Long. Light 1x6700K 32W,1x8000K 32W fluorescent on 4h, off 4h, on 4h
Temperature 77F,Eheim 2217, UV sterilizer – on for 10h night time.
Ferts-PPS Pro every day before light comes on.
I use to have air stone ON for 9h night time but there was high PH fluctuation and I stop it 3 days ago.
PH -6,5-6,8 , KH 6 , gKH 7 , Nitrite 0 , Ammonia 0 , Nitrate 20ppm , Phosphate 2pm , Iron 0.13-0.18ppm
Pressure CO2 1h before lights comes on 2bps - 25-35ppm
Why there is no pearling over the plants?
Do I have to put more light with shorter photo period or there is some other problem?
Please help me to have good looking healthy plants.
Attached Images
File Type: jpg a.jpg (94.3 KB, 16 views)
File Type: jpg b.jpg (80.4 KB, 16 views)
File Type: jpg c.jpg (92.9 KB, 16 views)
File Type: jpg d.jpg (92.3 KB, 16 views)
plamski is offline   Reply With Quote
Old 12-15-2009, 09:20 AM   #2
 
Angel079's Avatar
 
Looks like thread-fuzz algae mix to me, I don't see no green spot algae in the picture.
Often happening in newly set up tanks with ammonia or nitrate spikes - How long is your tank running now?
Also a sign of poor nutrition, do you use a comprehensive liquid fertilizer in there or only CO2?
Each w/c try to manually clean it off with a toothbrush and then vacuum off.
Angel079 is offline   Reply With Quote
Old 12-15-2009, 11:00 AM   #3
 
Quote:
Originally Posted by Angel079 View Post
Looks like thread-fuzz algae mix to me, I don't see no green spot algae in the picture.
Often happening in newly set up tanks with ammonia or nitrate spikes - How long is your tank running now?
Also a sign of poor nutrition, do you use a comprehensive liquid fertilizer in there or only CO2?
Each w/c try to manually clean it off with a toothbrush and then vacuum off.
Hello.I use dry ferts but I mix them with distilated water and then I poor them in to a tank.

Macro Solution

In 1 liter bottle:
59 grams K2SO4 (Potassium Sulfate)
65 grams KNO3 (Potassium Nitrate)
6 grams KH2PO4 (Mono Potassium Phosphate)
41 grams MgSO4 (Magnesium Sulfate)


Micro Solution

In 1 liter bottle:
80 grams of CSM+B or equivalent trace element mix

Dose 1 ml of each solution per ten gallons of tank size. Dose prior to lights turning on.
plamski is offline   Reply With Quote
Old 12-15-2009, 11:03 AM   #4
 
Angel079's Avatar
 
How often do you dose?

I don't see Iron nor Zinc in the mix? General comprehensive fert's also incl Boron & Copper as trace.

How often do you do w/c? and how much?
Angel079 is offline   Reply With Quote
Old 12-15-2009, 01:20 PM   #5
 
MoneyMitch's Avatar
 
seems like you are using a E.I type method here, massive amounts of light c02 and ferts. i agree with angel, you need iron in there any lack of fert can cause this not to mention plants need like 17 or so micro and macro nutrients to survive. i would get a all in one liquid fert and try that for about two three weeks and see how things work out for you. if that works to stop the algae i would then mimic what is in the fert is you want to continue using dry salts or just switch to the liquid ferts. sorry i cant help more im not too familliar with the EI method or even algae of this type but just a thought?
MoneyMitch is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Nasty Spot Algae!! AYE RUSS Beginner Saltwater Aquariums 5 12-20-2009 07:32 PM
Green spot algae Herky Beginner Freshwater Aquarium 7 08-17-2009 12:58 PM
VERY stubborn green spot algae Blaxicanlatino Beginner Freshwater Aquarium 8 04-12-2009 03:05 PM
please help!!!! green spot algae saber1971 Saltwater Fish Diseases 8 06-06-2008 08:39 PM
White Spot on Algae Eater tiffianylynn Freshwater and Tropical Fish 4 12-24-2007 11:18 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -5. The time now is 03:18 AM.