green nasty looking algea :(
Tropical Fish

Tropical Fish Keeping - Aquarium fish care and resources » Freshwater Fish and Aquariums » Beginner Freshwater Aquarium » green nasty looking algea :(

green nasty looking algea :(

This is a discussion on green nasty looking algea :( within the Beginner Freshwater Aquarium forums, part of the Freshwater Fish and Aquariums category; --> Hi, ever since i removed a few plants i had, I'm getting green algea buildups on the glass and green cloudy nasty looking water. ...

Check out these freshwater fish profiles
Blue Ram
Blue Ram
Red Phantom Tetra
Red Phantom Tetra
Reply
LinkBack Thread Tools vBmenu Seperating Image Search this Thread vBmenu Seperating Image
green nasty looking algea :(
Old 09-23-2008, 12:28 PM   #1
 
green nasty looking algea :(

Hi, ever since i removed a few plants i had, I'm getting green algea buildups on the glass and green cloudy nasty looking water. I have a 35 gallon with 5 (small to medium) african lake malawi cichlids. I have an 80 watt lighting system (Orbit by Current-USA) that i run for 7 hours a day (2pm - 9pm). I have a penguin 350 biowheel filter. the tank is no where near a window. I'm using freshwater sand as a substrate. I never had any algea problems until I removed the plants and upgraded the lights. I have been doing weekly or even biweekly h20 changes and have had no issues until i removed my plants and got the new lights. Since the cloudy h20 started, i have been doing 33% h20 changes every 3 days for the last 2 weeks and it gets little bit better but in a day or 2 looks horrible again. I'm thinking of getting new plants this weekend. Besides lowering the lighting times is there anything else that might help? My tank used to be crystal clear and it would last for like a week and a half and still look great. Now it's a different story.
dolphinsrok is offline   Reply With Quote
Old 09-23-2008, 10:59 PM   #2
 
SheyFirestar's Avatar
 
why did you upgrade the lights if you were taking the plants out? did your cichlids uproot them a lot?

algae blooms are results of too much light and too much fertilizer really. and since you increased your lights and took away the only thing using your fertilizer(nitrates) youve got a bloom on your hands. if your going to plant the tank again that will help. plants will compete with algae for nutrients. total blackouts can really do wonders for algae. personally id opt for the blackout over adding plants. even doing the blackout and once you have your algae under control then adding your plants which will help prevent the return of your algae problem.
SheyFirestar is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Algea explosion! My water is Green... what to do? strawnj Beginner Freshwater Aquarium 13 03-23-2010 08:53 PM
Green Algea Nessie Beginner Saltwater Aquariums 25 06-16-2009 01:36 AM
Rid of green algea milindsaraswala Beginner Planted Aquarium 0 07-16-2008 01:08 PM
GREEN HAIR ALGEA seba Saltwater Fish Diseases 2 05-20-2008 04:52 PM
bright green algea black&whiteclowns Saltwater Fish Diseases 3 04-30-2007 05:10 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -5. The time now is 04:07 PM.