Fluval 305 HELP!!!
Tropical Fish

Tropical Fish Keeping - Aquarium fish care and resources » Freshwater Fish and Aquariums » Beginner Freshwater Aquarium » Fluval 305 HELP!!!

Fluval 305 HELP!!!

This is a discussion on Fluval 305 HELP!!! within the Beginner Freshwater Aquarium forums, part of the Freshwater Fish and Aquariums category; --> I just purchased at 55 gallon tank today, along with everything needed including a Fluval 305 filter. I have been trying to get it ...

Check out these freshwater fish profiles
Cherry Barb
Cherry Barb
Mosquito Rasbora
Mosquito Rasbora
Reply
Old 12-15-2008, 12:26 AM   #1
 
Fluval 305 HELP!!!

I just purchased at 55 gallon tank today, along with everything needed including a Fluval 305 filter. I have been trying to get it to work....and I CANT!! When i turn it on it vibrates but does not perform any sort of flitering (no suction or expulsion of water).

Does anyone know what might be the problem??

THANKS!
bhancz is offline   Reply With Quote
Old 12-15-2008, 12:37 AM   #2
 
onefish2fish's Avatar
 
i dont know if the 305 model has a "primer" on it, but im 98% sure it does.

prime that bad boy to get it full of water, or else you might burn out the pump

you can also pre fill it as much as you can with water to get it jump started.
onefish2fish is offline   Reply With Quote
Old 12-15-2008, 10:33 AM   #3
 
Tyyrlym's Avatar
 
Yeah, sounds like a dry pump. Check your manual on how to prime the pump and see how it goes then.
Tyyrlym is offline   Reply With Quote
Old 12-15-2008, 12:03 PM   #4
 
i just got a new 305 too. make sure ur valve is all the way down, that was my mistake. I was trying to prime it with the valve up so no water was comming in. After u prime it for a little bit u should ehar lots of water flowing down. when u stop hearing the water flowing down, THEN u plug it in.
SinCrisis is offline   Reply With Quote
Old 12-15-2008, 01:55 PM   #5
 
Quote:
Originally Posted by SinCrisis View Post
i just got a new 305 too. make sure ur valve is all the way down, that was my mistake. I was trying to prime it with the valve up so no water was comming in. After u prime it for a little bit u should ehar lots of water flowing down. when u stop hearing the water flowing down, THEN u plug it in.
GRRRR this is getting frustrating. I have checked, double checked, and triple checked to make sure everything is connected properly and that the valve is all the way down. Still no go. How long did you have to prime it? I tried pumping that thing a million times and no water will flow into the filter.

anything else it could be?
bhancz is offline   Reply With Quote
Old 12-15-2008, 02:27 PM   #6
 
iamntbatman's Avatar
 
When I first set my 204 up, I couldn't get it flowing, either. I had to fill the canister with some tank water before the primer pump could get a good siphon going.
iamntbatman is offline   Reply With Quote
Old 12-15-2008, 03:18 PM   #7
 
Tyyrlym's Avatar
 
Fill the body with water and then suck would be another option. Not pretty but if that doesn't work you know something's messed up with the plumbing.
Tyyrlym is offline   Reply With Quote
Old 12-15-2008, 03:25 PM   #8
 
i primed mine like 5 times really quickly and hard and that was enough to get the water goin. also make sure u dont have any holes in ur tubing cuz then u would just be sucking air in
SinCrisis is offline   Reply With Quote
Old 12-15-2008, 04:02 PM   #9
 
Thanks for help guys, I FINALLY got it going. The trick was to fill up the tubes with water....i guess there was too much air in the filter for it to get started.
bhancz is offline   Reply With Quote
Old 12-16-2008, 12:22 AM   #10
 
nice
SinCrisis is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
fluval u3 djj123 Beginner Freshwater Aquarium 1 03-20-2010 10:55 PM
Fluval 305 with a 55G? blacksheep Beginner Freshwater Aquarium 3 02-17-2010 02:39 AM
Fluval 404 Matt Freshwater Aquarium Equipment 6 12-24-2008 10:08 PM
Fluval FX5 bwsmith Freshwater Aquarium Equipment 3 12-09-2008 06:14 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -5. The time now is 11:39 PM.