Filter problem, help please - Tropical Fish Keeping - Aquarium fish care and resources
 
LinkBack Thread Tools
post #1 of 4 Old 08-13-2010, 10:43 PM Thread Starter
New Member
 
Filter problem, help please

Did my usual fish maintenance, took the filter off to clean it because it started growing hair algae inside of it, and ever since I put it back in I can't get it to work...normally when I plug it back in it will gurgle and I just take some water from the tank to fill it up and get it going...but now it won't do anything...no gurgle or anything, if I hold it up to my hear I can hear a really quiet electrical buzz coming from it...but it won't do it's wonderful filter job...kinda worried about the oxygen levels in the tank dropping, but it's pretty heavily planted so I guess this won't be a problem...but any advice? Anyone else ever have this problem?

Unfortunately I don't know what kind of filter it is because it was with the tank already when I acquired it
PrettyKitty187 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 08-13-2010, 10:48 PM
New Member
 
Mettalikatt's Avatar
 
If you can I'd detach the intake tube hopefully giving you a view of the fan that drives the water through and make sure that the intake isn't clogged or that your motor isn't siezed up from algae

Because you can't starve us out and you can't make us run, Cause we'se them ole boys raised on shotguns.
http://www.fishtanks.net/fishtank.php?fishtank=2245
http://www.fishtanks.net/fishtank.php?fishtank=2376
Mettalikatt is offline  
post #3 of 4 Old 08-13-2010, 11:01 PM Thread Starter
New Member
 
SUCCESS!! Thank you much!

Took the hose off and scrubbed out the spot it goes in with a toothbrush and now it works, much appreciated dude
PrettyKitty187 is offline  
post #4 of 4 Old 08-13-2010, 11:20 PM
New Member
 
Mettalikatt's Avatar
 
:) Happy to help

Because you can't starve us out and you can't make us run, Cause we'se them ole boys raised on shotguns.
http://www.fishtanks.net/fishtank.php?fishtank=2245
http://www.fishtanks.net/fishtank.php?fishtank=2376
Mettalikatt is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
? problem using a pool filter rsheets Beginner Freshwater Aquarium 4 05-28-2010 12:41 PM
New Tank Filter Problem brittanyb157 Beginner Freshwater Aquarium 1 07-31-2008 05:39 PM
Filter Problem Watermello Beginner Freshwater Aquarium 7 07-08-2008 07:44 PM
Plants & Filter = Problem? Nick Beginner Planted Aquarium 12 09-02-2006 02:23 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome