Filter Broke... - Tropical Fish Keeping - Aquarium fish care and resources
 
LinkBack Thread Tools
post #1 of 4 Old 08-09-2012, 10:01 PM Thread Starter
New Member
 
FluffyWolf2's Avatar
 
Filter Broke...

Hello all, I have an aqueon quietflow 20 that came with my tank 3 months ago. Tonight during a water change just stopped and I cannot get it to restart. I wanted to ask for suggestions on what I could do to see if it is really broke. It just doesn't make any noises or does nothing when I plug it in. If it can't be fixed any recommendations on what to replace it with? Tank is 10 gallons.
Posted via Mobile Device
FluffyWolf2 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 08-10-2012, 05:48 AM
Member
 
jaysee's Avatar
 
Is the motor getting hot when it's plugged in? If so, the impeller could be stuck and the impeller an housing need cleaning.

125 - BGK, chanchito cichlid, pictus cats, silver dollars, palmas bichir
125 - cichlids (severums, bolivian rams, chocolate), rainbows ( turquoise, red), loaches (angelicus, zebra, kuhli and horseface), plecos (BN, RL and clown), denison barbs, tiretrack eel, pearl gouramis, betta
90 - Congo tetras, african knife, upside down cats, spotted ctenopoma, kribensis, delhezzi bichir
2.5 - betta
jaysee is offline  
post #3 of 4 Old 08-10-2012, 07:11 AM
TFK Moderator
 
Romad's Avatar
 
That would be my suggestion too. Clean out the impeller area. I use Q-tips to get in all the small areas. Good luck.

Animal testing is a terrible idea; they get all nervous and give the wrong answers.
Romad is offline  
post #4 of 4 Old 08-12-2012, 10:43 AM
New Member
 
Quote:
Originally Posted by jaysee View Post
Is the motor getting hot when it's plugged in? If so, the impeller could be stuck and the impeller an housing need cleaning.
This i have a brand new whisper that will stop once in a while, just unplug it and pull apart and clean
R1junkie is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
filter broke, buying a new one slojko Beginner Freshwater Aquarium 8 07-20-2012 07:26 PM
broke off fin tbarrs Tropical Fish Diseases 1 07-16-2008 11:51 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome